-
Notifications
You must be signed in to change notification settings - Fork 25
/
Copy pathNumber Pattern 2.java
60 lines (52 loc) · 1.06 KB
/
Number Pattern 2.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
// Number Pattern 2
// Send Feedback
// Print the following pattern
// Pattern for N = 4
// 1
// 23
// 345
// 4567
// Input Format :
// N (Total no. of rows)
// Output Format :
// Pattern in N lines
// Sample Input :
// 5
// Sample Output :
// 1
// 23
// 345
// 4567
// 56789
import java.util.Scanner;
public class Solution {
public static void main(String[] args) {
/* Your class should be named Solution.
* Read input as specified in the question.
* Print output as specified in the question.
*/
Scanner s=new Scanner(System.in);
int N=s.nextInt();
int i=0;
int j;
int count;
int space=N-1;
while(i<=N)
{ j=i;
count=0;
space=N-i;
while(space>0)
{
System.out.print(" ");
space--;
}
while(count<i)
{ System.out.print(j);
j++;
count++;
}
i++;
System.out.println();
}
}
}