-
Notifications
You must be signed in to change notification settings - Fork 25
/
Copy pathStar Pattern.java
56 lines (47 loc) · 877 Bytes
/
Star Pattern.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
// Star Pattern
// Send Feedback
// Print the following pattern
// Pattern for N = 4
// *
// ***
// *****
// *******
// Input Format :
// N (Total no. of rows)
// Output Format :
// Pattern in N lines
// Sample Input 1 :
// 3
// Sample Output 1 :
// *
// ***
// *****
import java.util.Scanner;
public class Solution {
public static void main(String[] args) {
/* Your class should be named Solution.
* Read input as specified in the question.
* Print output as specified in the question.
*/
Scanner sc=new Scanner(System.in);
int n=sc.nextInt();
int space=n-1;
int i=1;
while(i<=n)
{ int j=1;
space=n-i;
while(space>0)
{
System.out.print(" ");
space--;
}
while(j<=((2*i)-1))
{
System.out.print("*");
j+=1;
}
System.out.println("");
i+=1;
}
}
}